Como conseguir instalar DraftSight en Ubuntu Natty 64 bits

El problema principal es el tener instalado Ubuntu de 64 bits, supongo que para el caso de 32 bits, la cosa no tendrá ningún problema.

Después de haber estado usando DraftSight en Maverick, tal y como vimos en  el artículo Al fin, CAD del bueno en Ubuntu cuando he ido a instalarlo en Natty, me aparece un extraño problema, que parece que es generalizado y es referente a la librería libexpat1 que según parece requiere una versión 2.0.1-4 o superior, pero es que en Natty viene la 2.0.1-7, con lo que la cosa no pinta nada bien.

He estado probando casi todo, y al final he leído la solución en el forum italiano de Ubuntu, y funciona, ya lo tengo instalado, probado y funcionando.

¿Cómo hacerlo?

Lo primero que tenemos que hacer es exactamente igual que en Al fin, CAD del bueno en Ubuntu, instalamos las dependencias:

sudo apt-get install libdirectfb-extra libxcb-render-util0

Y ahora es donde viene el asunto, vamos a descomprimir el archivo debian, para ello creo un directorio llamado «ds» y un directorio «DEBIAN»:

mkdir -p ~/temporal/ds/DEBIAN/

Descomprimimos los archivos de control:

dpkg-deb --control DraftSight.deb ~/temporal/ds/DEBIAN/

Descomprimimos el paquete:

dpkg-deb --extract DraftSight.deb ~/temporal/ds/

Siguiente paso copiamos el contenido de lo directorio «/opt»:

sudo cp -r ~/temporal/ds/opt/* /opt

 

y lo mismo para el directorio «/var»:

sudo cp -r ~/temporal/ds/var/* /var

 

Y por último ejecutamos los comandos de preinstalación y postinstalación:

cd ~/temporal/ds/DEBIAN
sudo ./preinst
sudo ./postinst

 

Ahora ya está completamente instalado, solo te queda eliminar el directorio y a correr:

rm -rf ~/temporal/ds

 

Ya está, ya no tienes excusa para continuar dibujando con tu CAD.

Vía | ubuntu-it

6 comentarios en “Como conseguir instalar DraftSight en Ubuntu Natty 64 bits

  1. Sordoman hace 10 años

    Si señor!!! mil gracias hacia dias que buscava una solucion!!

  2. Ubntu991 hace 10 años

    hola quisiera saber como desinstalarlo ya que lo instale con los pasos y que estan aqui pero instale bricscad y ya no me sirve el draft pero no me salen los paquetes en synap ni en el centro de software ayuda por favor 

  3. Juand hace 10 años

    libxcb-render-util0 no se encuentra y no se instala… No puedo seguir a partir de aquí
     

  4. Edni_1995 hace 10 años

    buenas  libxcb-render-util0 este no se instala hermano busco y busco solución a esto y no la encuentro ayúdame si tienes la solución me aparece esto E: No se ha podido localizar el paquete libxcb-render-util0 como hagoo te lo agradeceria

  5. Luis hace 8 años

    Gracias !!!!! una maravilla!!!!

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *