Unity Lens Translator o como traducir desde el Dash con Apertium

Introducción

Como ya adelanté el otro día en el artículo «Liberado Translate-me 0.4.1.0«, he estado trabajando en otra Lente con el objetivo de facilitarnos la vida un poco mas si cabe. Se trata de una Lente que te permite realizar traducciones directamente desde el Dash utilizando para ello el mismo motor que empleaba Translate-me,  Apertium, y el funcionamiento es realmente muy similar, sencillo y sobre todo cómodo.

ult

Unity-Lens-Translator

Instalación

Lo primero es añadir el repositorio y actualizar:

sudo add-apt-repository ppa:atareao/lenses && sudo apt-get update

Una vez añadido el repositorio y actualizado, el siguiente paso, es instalar la Lente, que lo puedes hacer desde el Centro de Software de Ubuntu, haciendo clic en el siguiente enlace,

Instalar Unity Lens Translator

o bien, desde el terminal, ejecutando el siguiente comando:

sudo apt-get install unity-lens-translator

El siguiente paso es instalar los diccionarios que necesites, tal y como hacíamos con Translate-me. Por defecto instalará el diccionario Inglés-Español, Español-Inglés, pero puedes instalar mas diccionarios desde el Centro de Software de Ubuntu, buscando “apertium”, o directamente desde los siguientes enlaces:

Instalar diccionario para traducir entre español y portugués

Instalar diccionario para traducir entre español y gallego

Instalar diccionario para traducir entre portugués y catalán

Instalar diccionario para traducir entre esperanto y catalán

Instalar diccionario para traducir entre inglés y catalán

Instalar diccionario para traducir entre esperanto y español

Instalar diccionario para traducir entre occitano y español

Instalar diccionario para traducir entre francés y catalán

Instalar diccionario para traducir entre español y rumano

Instalar diccionario para traducir entre euskera y español

Instalar diccionario para traducir entre occitano y catalán

Instalar diccionario para traducir entre francés y español

Instalar diccionario para traducir entre inglés y español

Instalar diccionario para traducir entre portugués y gallego

Instalar diccionario para traducir entre español y catalán

Funcionamiento

Una vez instalado, tienes que salir de la sesión y volver a entrar. Seleccionas la Lente de traducción que tiene un icono que parece un altavoz o algo parecido, y seleccionas, en Filtros el diccionario que quieres utilizar, y por supuesto introduces lo que quieres traducir.

ult

Conclusiones

Las cosas como son, habrá quien le guste Unity y quien no le guste, pero nadie puede negar lo cómodo que es tener al alcance de tus manos, y sin necesidad de abrir otra aplicación un diccionario para buscar aquellas palabras o traducir aquello que no entiendes.
Al igual que sucede con Translate-me, el echo de que utilice Apertium como motor de traducción, es por el cambio en la politica de Google respecto a su traductor. Apertium es un motor de código abierto, frente al traductor de Google.

14 comentarios en “Unity Lens Translator o como traducir desde el Dash con Apertium

  1. Carlos Molina hace 9 años

    Creo que esta línea:
    sudo add-apt-repository ppa:atareaolenses && sudo apt-get update
    tiene el símbolo » equivocado; debiese ser ‘/’, ¿no?

      1. El atareao hace 9 años

         He hecho una copia para Oneiric Ocelot, que también puedes instalar desde el mismo repositorio. Yo no lo he probado, porque ahora mismo en mi equipo ya no tengo esa versión de Ubuntu.

        Si no te importa, si lo pruebas, me dices a ver como te ha ido la experiencia.

        Gracias y un saludo.

        1. Carlos Molina hace 9 años

           Lamentablemente obtengo el siguiente error:

          $ sudo apt-get install unity-lens-translator
          Leyendo listas de paquetes… Hecho
          Creando árbol de dependencias      
          Leyendo la información de estado… Hecho
          No se pudieron instalar algunos paquetes. Esto puede significar que
          usted pidió una situación imposible o, si está usando la distribución
          inestable, que algunos paquetes necesarios no han sido creados o han
          sido movidos fuera de Incoming.
          La siguiente información puede ayudar a resolver la situación:

          Los siguientes paquetes tienen dependencias incumplidas:
           unity-lens-translator : Depende de: gir1.2-unity-5.0 pero no es instalable
                                   Depende de: gir1.2-dee-1.0 pero no es instalable
          E: No se han podido corregir los problemas; ha retenido paquetes rotos.

          ¿Sería posible cambiar esas dependencias por paquetes disponible en Oneiric?

          1. El atareao hace 9 años

             @google-a94120b192fec92ed9606330613b3db6:disqus se me olvidó por completo, el cambio de dependencias. Voy a ver si se puede resolver ¿?

            Saludos

    1. El atareao hace 9 años

       @google-a94120b192fec92ed9606330613b3db6:disqus ya está corregido, muchas gracias por tu colaboración.

      Un saludo.

  2. acutbal hace 9 años

    Instalada y funcionando perfectamente en Ubuntu Precise. Muchas gracias por tu enorme esfuerzo!!!

  3. Ludwing Argenis hace 9 años

    Esta prestación para el Dash si estuvo realmente exelente atareao; ahora si toma mas sentido la existencia del Dash de Unity con Lenses como este, ya que es verdaderamente productivo. No has pensado en trabajar para Canonical Atareao o en participar en el Ubuntu App Showdown por lo menos?

  4. Hereje Blasfemo hace 9 años

    ¡Hola, Atareao! Gracias por el nuevo aporte para el dash. Solo te notifico un pequeño error: siempre que pincho en el loro me va a una página de error de WordReference, un 404. Posiblemente es por la ruta que tiene el programita, que lleva a una URL del tipo http://www.wordreference.com/palabra, mientras que las rutas directamente desde WordReference son más complicadas, como por ejemplo:

    http://www.wordreference.com/es/en/translation.asp?spen=hola

    Un abrazo y gracias de nuevo.

    1. El atareao hace 9 años

      Hola @Herejeblasfemo:disqus ,

      Voy a actualizar las distintas aplicaciones para Quantal, y revisaré este error. Actualmente Unity Lens Translator no utiliza Wordreference para las traducciones, sino que utiliza Apertium.

      1. Hereje Blasfemo hace 9 años

        Gracias, atareao, pero lo estoy utilizando en Precise, no en Quantal, y no sé cuál es el problema, porque se instala el diccionario apertium-en-es, pero luego, como te decía, se intenta ir a WordReference.

        Un saludo y gracias por el esfuerzo. Por cierto, my-weather-indicator ya hace varios meses que no me da ningún problema, que se me olvidó decírtelo ¡Enhorabuena!

        1. El atareao hace 9 años

          Hola,

          me expliqué mal, me refería a que voy a actualizar la Lente para Quantal, y cuando lo haga la revisaré también para Precise. El problema, se exactamente donde está, intentaré subsanarlo en breve.

          Saludos y Gracias
          El 22/09/12 18:35, Disqus escribió:

  5. rbarra hace 9 años

    Hola, me sumo a las felicitaciones y me pregunto, al igual que @Herejeblasfemo:disqus, si se podrá corregir el error al pinchar en el loro. Saludos desde Chile!

    (Aprovecho de hacerte una pregunta… ¿qué plugin de WordPress estás usando para los comentarios en este sitio? Está buenísimo 🙂

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *