Instalando la impresora y el escáner otra vez

Como siempre el problema de actualizar Ubuntu a una nueva versión es que tienes que instalar todos los equipos periféricos, en mi caso la impresora y el escaner:

  • Impresora Epson AcuLaser M1200
  • Escáner Epson Perfection 3490 PHOTO

Y normalmente, siempre aparece algún inconveniente que en la edición anterior de Ubuntu no existía, o que no recuerdas si existía o no.

Para instalar el escaner he seguido los pasos que puse en el anterior artículo Instalar el escaner EPSON PERFECTION 3490 PHOTO en Ubuntu, con la desagradable sorpresa que tenía problemas con los 64 bits y me ha sido «inicialmente» imposible, posteriormente lo he conseguido instalar y os cuento como.

En el caso de la impresora, tres cuartos de lo mismo he seguido los pasos de mi artículo Impresora AcuLaser M1200 en Ubuntu y tararí que te vi. Me salía un bonito error: «necesita el paquete ijs_server_epsonepl». Esto ya lo comentó en su día Eduardo Romero Q.

En fin como ves la cosa se las pintaba pardas, pero…, por si acaso lo dudabas le he dado a Python, y ya está un par de scripts para que funcionen ambas si problemas:

Poniendo en marcha el escaner EPSON PERFECTION 3490 PHOTO

En lugar de instalar los paquetes indicados en el artículo Instalar el escaner EPSON PERFECTION 3490 PHOTO en Ubuntu, puesto que en el caso de 64 bits aparecen problemas de dependencias irresolubles, la solución es más sencilla. Simplemente te tienes que realizar los siguientes pasos:

  • descargar el archivo esfw52.bin
  • lo descomprimes y lo copias en /etc/sane.d
  • editas /etc/sane.d/snapscan.conf
    • en la línea que empieza por firmware pones: firmware /etc/sane.d/esfw52.bin

Otra solución, como he mencionado antes es utilizar el script que he preparado para estos efectos, simplemente lo descargas desde aquí, le das permisos de ejecución y lo ejecutas. Ya está.

Poniendo en marcha la impresora EPSON ACULASER M1200

Los primeros pasos a realizar son exactamente igual que lo indicado en el artículo, Impresora AcuLaser M1200 en Ubuntu, sin embargo aparece el error, que he mencionado «necesita el paquete ijs_server_epsonepl». Para resolver este pequeño problema, tienes que descargar el archivo epsoneplijs-0.4.1.tgz

lo descomprimes, lo configuras, lo compilas, lo instalas y copias ijs_server_epsonpl en /usr/bin. Es decir:

cd ~
wget https://downloads.sourceforge.net/project/epsonepl/epsonepl/0.4.1/epsoneplijs-0.4.1.tgz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fepsonepl%2Ffiles%2F&ts=1286799756&use_mirror=heanet
tar -xvzf epsoneplijs-0.4.1.tgz
cd ~/epsoneplijs-0.4.1
./configure
make
sudo make install
sudo cp ijs_server_epsonpl /usr/bin
sudo service cups restart

Es posible que sea necesario que instales algún paquete para compilar el archivo:

sudo apt-get install build-essential

Igual que para el escáner, hice otro script para facilitarte un poquito la vida, que puedes descargar desde aquí. Lo descargas, le das permisos de ejecución y lo ejecutas. Ya está.

En este script he considerado que ya tenías instalados build-essential, sino lo instalas desde aquí

1 comentario en “Instalando la impresora y el escáner otra vez

  1. darzee hace 11 años

    Pos será que mis periféricos son viejos pero jamás (si, si, he dicho jamás) he tenido que buscar drivers de nada en los cuatro años que llevo con Ubuntu y distros derivadas (últimamente con Linux Mint 9 Isadora KDE).
    Incluso me pasó algo gracioso. Tenía la webcam, una Logitech, enchufada a la torre por inercia ya que hacía varios años que Logitech no servía drivers para ese modelo y por tanto no funcionaba. Un día alguien me abrió una conversación por mensajería y Kopete me dio la opción de abrir la webcam. Dije que sí y ¡Toma ya! mi careto sorprendido apareció en la pantalla… Mi webcam que llevaba varios años en coma funcionaba a la primera.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *