479 - Actualizando My-Weather-Indicator para Linux

479 - Actualizando My-Weather-Indicator para Linux

Llegó el momento de actualizar My-Weather-Indicator para #Linux, esta herramienta que se sitúa en el área de indicadores y te informa de la #meteorológía

1:25
-3:15

Hace algo mas de 10 años desarrollé la aplicación My-Weather-Indicator. Un sencillo indicador para tener el tiempo, siempre disponible en el área de indicadores de tu entorno de escritorio Linux. Principalmente pensada para Ubuntu, aunque posteriormente le he ido dando soporte a otros entornos de escritorio y otras distribuciones. En este episodio del podcast, te hablo sobre esta aplicación, el trabajo que ha conllevado, y la última actualización que he hecho.

Actualizando My-Weather-Indicator

Actualizando My-Weather-Indicator para Linux

Sobre My-Weather-Indicator

My-Weather-Indicator es una aplicación de código abierto que se utiliza para mostrar información del tiempo en el panel del sistema de Linux. Proporciona información detallada sobre el clima, como la temperatura actual, la humedad, la velocidad del viento, la dirección del viento y la previsión del tiempo para los próximos días.

Además, My-Weather-Indicator también permite a los usuarios ver la información del tiempo de varias ubicaciones, lo que es útil para aquellos que viajan con frecuencia o para aquellos que tienen familiares y amigos en diferentes partes del mundo. La aplicación se integra bien con el sistema de notificaciones de Linux y permite a los usuarios configurar alertas meteorológicas personalizadas.

My-Weather-Indicator es una aplicación de código abierto que se utiliza para mostrar información del tiempo en el panel del sistema de Linux. Proporciona información detallada sobre el clima, como la temperatura actual, la humedad, la velocidad del viento, la dirección del viento y la previsión del tiempo para los próximos días.

Además, My-Weather-Indicator también permite a los usuarios ver la información del tiempo de varias ubicaciones, lo que es útil para aquellos que viajan con frecuencia o para aquellos que tienen familiares y amigos en diferentes partes del mundo. La aplicación se integra bien con el sistema de notificaciones de Linux y permite a los usuarios configurar alertas meteorológicas personalizadas.

Sobre la aplicación

Desde sus inicios, tuve muchos problemas, al igual que otros desarrolladores con el soporte de los distintos proveedores de servicios meteorológicos. Pero además al tener la posibilidad de elegir diferentes ubicaciones, también he tenido los correspondientes problemas con servicios de geoposicionamiento.

Creando el paquete en Manjaro

Un problema con el que me he encontrado es crear el paquete para Ubuntu pero en Manjaro. Esto lo he resuelto utilizando Podman, y en concreto este Dockerfile,

FROM ubuntu


RUN apt-get update -y && \
    apt-get update -y && \
    apt-get upgrade -y && \
    apt-get install -y build-essential \
                      binutils \
                      lintian \
                      debhelper \
                      dh-make \
                      gnupg2 \
                      devscripts

WORKDIR /app
CMD ["/bin/bash", "/app/mybuilder.sh"]

Para construir la imagen, tan sencillo como ejecutar el siguiente comando,

podman built -t atareao/ubuntu-packager .

Y posteriormente para subir el paquete al PPA, tan sencillo como ejecutar este comando

podman run -v "$PWD/:/app" \
           -v "/home/${USER}/.gnupg:/root/.gnupg" \
           atareao/ubuntu-packager

El hecho de montar el volumen de ~/.gnupg es simplemente para poder utilizar la clave gpg con la que firmo los paquetes.

El script que utilizo es muy sencillo, y simplemente hace operaciones básicas, como extraer el nombre y la versión de la aplicación, para posteriormente, ejecutar un simple dput ppa:atareao/test y poco mas.

Con esto tan sencillo, es como he conseguido resolver el problema de subir un paquete al PPA.


Espero que te haya gustado este nuevo episodio del podcast. Si puedes, te agradecería una valoración en iVoox y/o en Apple Podcast.

Recuerda que este es un podcast suscrito a la red de podcast de Sospechoso habituales

Te puedes suscribir a esa fantástica red de podcast en feedpress.me/sospechososhabituales

Por último y como te digo siempre, recuerda que la vida son dos días y uno ya ha pasado.

Disfruta como si no hubiera un mañana y si puede ser con Linux, mejor que mejor.

6 comentarios en “Actualizando My-Weather-Indicator para Linux

  1. DO
    Dominique Aubert hace 10 meses

    Hola
    Tengo tu aplicación instalada desde años y me gusta. Pero hace algunos días dejo de funcionar, supongo que tiene ver con la actualización. Estoy con Ubuntu 22.04.2 LTS.
    La desinstalé, lo volví a instalar y sigue el problema igual. Arriba en la barra solo hay tres puntos y cuando voy a las preferencias hay un mensaje de error que me pregunta si quiero enviar estos datos a Ubuntu..
    Supongo que estas muy ocupado. No es el fin del mundo pero me gustaba tu aplicación.
    Gracias por leerme.

    1. AT
      atareao hace 10 meses

      He subido una nueva actualización… Cuando puedas instala y me cuentas.
      Saludos

      1. DO
        Dominique Aubert hace 10 meses

        Hola Lorenzo
        Gracias por tus esfuerzos.
        He desinstalado la aplicación y la he vuelto a instalar. Sigue igual. A lo mejor, lo hago mal.
        Me imagino que eso implica mucho trabajo para ti pero no dudes en darme algunos consejos si puedes.
        Muchas gracias
        , Francia

  2. JA
    Jaime hace 10 meses

    Hola, atareao, llevaba usando tu aplicación desde que topé con ella (ya hace varios años). Me paraece una maravilla. Al dejar de funcionar estos días, supuse algo parecido a lo que comentas en el «post». He inentado instalarla según tus indicaciones y no soy capaz. Uso MX Linux 21.3, con Xfce 4.18, basado en debian con el kernel Linux 5.10.
    Por si te sirve de información, me da varios errores:
    gpg: caja de claves ‘/tmp/tmpn_5ikmih/pubring.gpg’ creada
    gpg: /tmp/tmpn_5ikmih/trustdb.gpg: se ha creado base de datos de confianza
    gpg: clave 6A9653F936FD5529: clave pública «Launchpad PPA for atareao» importada
    gpg: Cantidad total procesada: 1
    gpg: importadas: 1
    gpg: no se han encontrados datos OpenPGP válidos
    —————————————————————————————–
    «dpkg-deb: error: el archivo `/var/cache/apt/archives/my-weather-indicator_0.10.1-0extras23.04.00_all.deb’ contiene un miembro de datos `control.tar.zst’ ininteligible, abandono
    dpkg: error al procesar el archivo /var/cache/apt/archives/my-weather-indicator_0.10.1-0extras23.04.00_all.deb (–unpack):
    el subproceso dpkg-deb –control devolvió el código de salida de error 2
    ——————————————————————————————————————————————————-
    Se encontraron errores al procesar:

    dpkg-deb: error: el archivo `/var/cache/apt/archives/my-weather-indicator_0.10.1-0extras23.04.00_all.deb’ contiene un miembro de datos `control.tar.zst’ ininteligible, abandono
    dpkg: error al procesar el archivo /var/cache/apt/archives/my-weather-indicator_0.10.1-0extras23.04.00_all.deb (–unpack):
    el subproceso dpkg-deb –control devolvió el código de salida de error 2

    —————————————————————————————————————
    /var/cache/apt/archives/my-weather-indicator_0.10.1-0extras23.04.00_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  3. GE
    George Mtz hace 10 meses

    Hola, buenas tardes ya he actualizado app pero la ubicación de la informacion que esta mostrando es erronea, como solucionar esto?

    1. AT
      atareao hace 10 meses

      ¿Que información es errónea? Me puedes dar mas detalle para que pueda ayudarte?
      Gracias

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *